AWS has confirmed an additional localized power issue affecting Availability Zone mec1-az3 in the ME-CENTRAL-1 (UAE) Region. At this time, only mec1-az1 remains operational for existing workloads. New instance launches in the region are currently not possible.
Multiple AWS services, including EC2, S3, and DynamoDB, are experiencing elevated error rates and latency.
Current Situation
1. mec1-az2 and mec1-az3 are unavailable
2. mec1-az1 remains operational for existing instances
3. Region-wide instance launches are currently failing
4. Cross-service API error rates remain elevated
Mitigation Actions
1. We have completed failover procedures and migrated affected deployments to the remaining healthy Availability Zone.
2. All impacted workloads have been stabilized under a single-AZ operational mode.
3. Once additional Availability Zones are restored, we will rebuild the multi-AZ high-availability cluster architecture.
Operational Mode
At this stage, deployments in the UAE region are running in temporary single-AZ mode. High availability across multiple Availability Zones will be restored once AWS confirms recovery.
Next Update
We continue to monitor AWS recovery efforts closely and will provide further updates as soon as additional Availability Zones become available.
Posted Mar 02, 2026 - 07:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 01, 2026 - 14:21 UTC
Identified
Due to a localized power issue affecting a single Availability Zone (mec1-az2) in the AWS ME-CENTRAL-1 (UAE) Region, multiple AWS services are experiencing increased error rates, connectivity interruptions, and latency.
Affected services may include EC2, EBS, RDS, and other dependent infrastructure components within the impacted Availability Zone.
Impact
1. Resources running in mec1-az2 may be unavailable or experience connectivity issues.
2. Increased API error rates and latency for workflows tied to the affected AZ.
3. New deployments in the UAE region are temporarily suspended.
Mitigation Actions
1. We have completed failover procedures for impacted customer deployments where possible.
2. Traffic has been shifted away from the affected Availability Zone.
3. Deployments in other Availability Zones within ME-CENTRAL-1 remain operational.
Customer Action Required
1. Review any external dependencies (e.g., load balancers, DNS records, NAT gateways, third-party integrations) to ensure traffic is directed to healthy Availability Zones.
2. Confirm redundancy configurations are functioning as expected.
3. Avoid launching new workloads in the UAE region until further notice.