GCP Outage Impacting Deployment Creation and Data Integration

Incident Report for EMQX Platform Status

Resolved

The earlier issue caused by a Google Cloud Platform (GCP) outage (https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW) has now been resolved.

We have verified that:

New deployments on the GCP platform are now functioning normally.

Data integration forwarding to GCP services such as Cloud Pub/Sub, Cloud PostgreSQL, and external authentication systems is also operating as expected.

If you experienced any issues during the incident, we recommend reviewing your data pipelines and integrations to ensure they have fully recovered.

Thank you for your patience while we monitored this issue.
Posted Jun 12, 2025 - 21:24 UTC

Update

We have also observed that, in addition to deployment creation issues, EMQX Cloud data forwarding to GCP-related integration services and external authentication systems is being affected by the ongoing GCP outage.

This includes, but is not limited to:

* GCP Pub/Sub

* GCP Cloud PostgreSQL

* Other GCP-hosted services used for external authentication or extensions

We strongly recommend that affected customers review the status of their data integrations and external authentication endpoints to ensure continued reliability.

We will continue monitoring the situation and provide updates as necessary.
Posted Jun 12, 2025 - 19:51 UTC

Identified

We are currently monitoring an incident affecting EMQX Cloud deployments on the GCP platform. Due to an upstream issue reported by Google Cloud (https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW), creating new deployments on GCP has been temporarily restricted since 19:06 UTC on June 12, 2025.

Existing deployments are not affected and continue to operate normally.

We are actively monitoring the situation and will provide updates as soon as the issue is resolved by the upstream provider.

Thank you for your understanding.
Posted Jun 12, 2025 - 19:45 UTC
This incident affected: EMQX Dedicated.