Partial Node Failure in US Region Serverless Cluster

Incident Report for EMQX Platform Status

Resolved

By 02:09 UTC, the failover was successfully completed. Based on continued monitoring, we confirm that the Serverless cluster has fully recovered and is operating normally.

We appreciate your patience and understanding.
Posted Jul 17, 2025 - 02:56 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 17, 2025 - 02:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 02:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2025 - 02:03 UTC

Investigating

At 01:56 UTC on July 17, 2025, we detected a partial node failure in the Serverless cluster in the US region due to underlying instance issues.

We immediately initiated a failover process to replace the affected nodes. During the failover, some clients connected to the impacted nodes may experience brief disconnections. However, client reconnections are not affected, and services are expected to recover automatically.

We are closely monitoring the situation and will provide further updates as needed.
Posted Jul 17, 2025 - 02:02 UTC
This incident affected: EMQX Serverless.