AWS US-East-1 Network Instability

Incident Report for EMQX Platform Status

Resolved

The AWS US-EAST-1 region incident has been fully resolved. AWS has confirmed that all services have returned to normal operations. All EMQX Cloud services in the us-east-1 region are now operating normally.

All connectivity issues have been resolved. MQTT connections, data integration connectors, and extended authentication services are functioning normally. We have re-enabled new resource provisioning in the us-east-1 region.
Posted Oct 21, 2025 - 00:48 UTC

Monitoring

AWS reports that recovery is progressing in the US-EAST-1 region. Their mitigations are showing early signs of success in several Availability Zones, with remaining AZs being addressed. We are observing gradual improvement in network stability and expect the intermittent connection issues to subside as AWS completes their recovery process.
Posted Oct 20, 2025 - 18:08 UTC

Identified

Additionally, data integration connectors and extended authentication services that depend on external resources in us-east-1 may experience intermittent timeout errors. This particularly affects configurations using AWS managed services such as Network Load Balancers, DynamoDB, Lambda, InfluxDB, and other endpoints hosted in the us-east-1 region.
Posted Oct 20, 2025 - 16:01 UTC

Investigating

AWS has confirmed network connectivity issues in the US-EAST-1 region affecting multiple services. While AWS reports early signs of recovery, we are observing continued network instability that may impact EMQX Cloud deployments in this region.

Please ensure your MQTT clients have automatic reconnection logic enabled. Clients with proper reconnect mechanisms will automatically restore connections without data loss. Most standard MQTT client libraries have this capability built-in by default.
Posted Oct 20, 2025 - 14:55 UTC
This incident affected: EMQX Serverless and EMQX Dedicated.